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Getting started

Protecting your business network with ESET NOD32 Antivirus is a straightforward
process that can be completed in a single afternoon for a basic installation. This
Basic Setup Guide will walk you through obtaining your ESET security software,
configuring your server computer and mirror, installing the software on client
computers and customizing clients’ settings. It is meant to accompany the ESET
Remote Administrator Installation Manual and User Guide. Be sure to read the
ESET Remote Administrator Installation Manual and User Guide in its entirety
and refer to it whenever necessary throughout the installation process.

Software components

There are three separate parts to your ESET security product: the ESET NOD32
Antivirus 4 Business Edition software itself, which exists both on your server
computer and on its clients, plus the ESET Remote Administrator Console (ERAC)
and the ESET Remote Administrator Server (ERAS). The Console should be installed
on the computer(s) you will be using to manage your network. The Server should be
installed on your server computer. Often in small-business installations, the server
computer is the same one you use to manage your network.

Section 1: Purchasing and
downloading your software

The first step toward protecting your network is obtaining the three ESET software
components mentioned above. If you have not already purchased an ESET security
product, please visit the link below:

http://www.eset.com/purchase/

This guide is aimed at users installing ESET NOD32 Antivirus. ESET Smart Security
can be used in a network environment, but the ESET Personal firewall, which
prevents unwanted interactions with remote computers, may require additional
configuration. For more information about ESET Smart Security on your network,
including safe push install instructions, see the KB Connection links at the right.

Select ESET NOD32 Antivirus 4 or ESET Smart Security and click the Business tab.
Out of the box, you may select the 5-User Bundle, the 10-User Bundle, the 15-
User Bundle, or more. All purchases of ESET NOD32 Antivirus 4 Business Edition
and ESET Smart Security Business Edition include ESET Remote Administrator
Console and ESET Remote Administrator Server.

Once you have purchased your ESET security product, you will receive an official
email from ESET containing your username and password in the body of the email
and your license file as an attachment to the email.

1.1 Username and password

Your username and password are a little different than many usernames and
passwords with which you may be familiar. They are not user-configured keys that
protect your own information. Rather, they are authentication keys that allow your
computer to interact with ESET's servers, permitting you to download your ESET
security product and later, authenticating your ESET security product to update its
Virus signature database to protect your network from evolving threats. You can't
choose or customize your username and password.

1.2 License file

Your license file — the attachment called nod32.lic — is a file that the ESET Remote
Administrator needs to manage your network of protected client computers. It
contains authentication for the number of seats (protected computers) and tells
the ESET Remote Administrator that you are entitled to protect and manage a set
number of computers, depending on the bundle you purchased. Save the license file
to your Desktop.

1.3 Getting your software
Visit the link below to ESET's Download Center to obtain your three components:

http://www.eset.com/download/

Click I have already purchased ESET software, take me to my download. Click the
Business Downloads tab and then expand the Business Users (32-bit) menu and click

the Download button beside ESET NOD32 Antivirus 4. Save the file to your Desktop to

keep things simple.

ESET NOD32 Antivirus, the ESET Remote Administrator
Server and the ESET Remote Administrator Console are
the three legs that support your malware defense system:
the antivirus software itself, the server pushing it out to
your clients and the administration console you use to
monitor the system.

‘stimated time: 30 minutes

Check the ESET Knowledgebase for more info:

Which ESET security solution should I install on
aserver?

bttp://kb.eset.com/esetkb]
[ndex?page=content&id=SOLN2299

How do | configure an ESET Smart Security
push installation to prevent loss of Internet
connectivity?

bttp://kb.eset.com/esetkbj
ndex?page=content&id=SOLN223

Push: the term“push” or“push install” refers to ESET
Remote Administrator’s capability to remotely send
and run installation packages on any computer in your
network.

Check the ESET Knowledgebase for more info:

What is authentication data (username and
password) and what is its purpose?

bttp://kb.eset.com/esetkb]
[ndex’page=content&id=SOLN373

Username and password examples:
Username: EAV-12345678
Pasword: 1a2zbc3defg

Check the ESET Knowledgebase for more info:

How do | update ESET Remote Administrator
with a new license file?

bttp://kb eset.com/esetkb]
ndex?page=content&id=SOLN54

NOTE: A different build of ESET NOD32 Antivirus is needed
for 64-bit computers. If you have any 64-bit computers on
your network, whether they are servers or workstations,
you will also need to download the 64-bit installer. If
none of the computers on your network are 32-bit, only
download the 64-bit build.


http://kb.eset.com/esetkb/index?page=content&id=SOLN373
http://kb.eset.com/esetkb/index?page=content&id=SOLN373
http://kb.eset.com/esetkb/index?page=content&id=SOLN540
http://kb.eset.com/esetkb/index?page=content&id=SOLN540
http://kb.eset.com/esetkb/index?page=content&id=SOLN2299
http://kb.eset.com/esetkb/index?page=content&id=SOLN2299
http://kb.eset.com/esetkb/index?page=content&id=SOLN2233
http://kb.eset.com/esetkb/index?page=content&id=SOLN2233

1.4 Enter your username and password
You will be prompted for your username and password from Section 1.1.

Enter them carefully. Both are case sensitive and the hyphen in the usernameis
required. Your password is 10 characters long (all lowercase) and if you choose to
copy and paste your username and password from the license email, be sure you
don't copy an extra space after either. Your password will never contain an“l’, it's a
numeral one (1). Alarge“0"is the numeral zero. A small“0” is the lowercase letter“o”.

Next, expand the Remote Administrator menu and download ESET Remote
Administrator Console and ESET Remote Administrator Server. You will again be
prompted for your username and password, as above. Save the files to your Desktop.

Section 2: Installation 'stimatedtime: B e

Once the three processes above (or four, if you also downloaded the 64-bit installer)
complete, you are ready to install. Sections 2.1 through 2.3 assume you are using 32-
bit installers. If some or all of your installers are for 64-bit computers, the file names
will be slightly different.

2.1 Remote Administrator Server

First, double click the installer .msi for ESET Remote Administrator Server (era_ IMPORTANT: Install the Remote Administrator Server on
server nt32 enu msi) the server that will be managing your network This computer

may be the terminal you are using, but it could also bea

) . . headless server in a server rack or offsite. Contact your
Agree to the End-User License Agreement and click Next. Select a Typical network administrator you're unsure.

installation and click Next. You will be prompted to browse to your nod32.lic file
(which you saved to your Desktop).

You are given the option to set connection passwords to the various clients and
servers on your network. Since we're keeping it simple here, you only need to set one
password, Password for Console (Administrator Access). This password protects
your control over your network. Click Set and choose a robust password you can
remember and don't share it. (You can go back and add other network passwords
later if you wish.) Click Next.

Last, enter your ESET-issued username and password (as in the web authentication
in Section 1.3.1). Enter them carefully and click Next. You can also copy and paste
your username and password directly from the license email. Click Next until the KB connection
installation progress bar appears.
Check the ESET Knowledgebase for more info:
Afterinstallation, the ESET Remote Administrator Server service launches

automatically_ How do | install ESET Remote Administrator

and configure a Mirror server?

2.2 Remote Administrator Console Fttp://kb eset.com/esetkb]
When the Server installation wizard process is completed, double-click the ESET ndextpage=contentéid=5OLNE

Remote Administrator Console installer (era_console_nt32_enu.msi). Install the
Console on the computer you plan to use to manage your network. This will likely
be the local computer you are using to run the installation wizard. Select Typical
installation and advance through the options by clicking Next until you can click
Install. The installation progress bar will appear.

2.3 Additional options

Because this is an ESET Remote Administrator Quickstart Guide, we're skipping over
a great deal of customizable options you may wish to explore at a later time.

ERA manual
For additional information about installations on Microsoft SQL, MySQL or Oracle
servers, and for a detailed list of which TCP ports must be open for ESET Remote Check the ESET Remote Administrator manual
Administrator to work properly, please consult Section 2 of the ESET Remote formore nfo:
Administrator Installation Manual. 21.2 Ports used

2.2 Basic installation guide


http://kb.eset.com/esetkb/index?page=content&id=SOLN814
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Section 3:
Setting up the Mirror server

Your ESET-protected client computers get regular updates to the Virus signature
database from ESET's servers. This keeps them current and protected from a
variety of evolving threats. But having all your clients connect to the ESET servers
independently would result in an unnecessary amount of traffic across your local
area network (LAN).

The solution is to create a Mirror server (a server that“mirrors” the content available
on ESET's servers) on your own LAN, so your clients only need to check locally for new
Virus signature updates and program component updates.

3.1 Mirror server setup

Open the ESET Remote Administrator Console by clicking Start - All Programs
- ESET » ESET Remote Administrator Console -» ESET Remote Administrator
Console. Verify that you are connected to the ESET Remote Administrator Server
(File » Connect).

In this guide, we're going to use the default Mirror server configuration using internal
HTTP. There are other options available, including using a local folder to house
update content, as well as instructions for creating replicated Mirror servers for
different LANs. See the KB Connection to the right for more information.

Click Tools » Server Options. Click the Updates tab and (you
guessed it) enter your ESET-issued username and password in
the Update username and Update password fields in the Server
Options window (Figure 1-1, at right). Click the Set Password...
button to enter your password.

Select the Create update mirror check box in the middle of the
window. Select the Provide update files via internal HTTP server
check box.

Click the Update now button to display a confirmation dialog
box ('This will first apply server options and then fire the event.
Continue?) Click Yes.

Adialog box will appear that says 'Event fired on the server! This message means
that your Mirror successfully checked for and downloaded update content from
ESET's servers. Click OK.

3.2 Testing your Mirror

Check that the Mirror server you just created is working. Open a web browser on a
client workstation (not the Server) and enter:

http://Testserver:2221/update.ver
(where “Testserver” is the name of your Server computer)

If your Mirror creation was successful, you will see a text file with information about
your Mirror (as in Fig 2-1, below). If it fails, you will get a standard connection failure
error.

'stimated time: 15 minutes

ERA manual

Check the ESET Remote Administrator manual for
more info:

2.2.3.3 How to install and configure the Mirror

KB connection

Check the ESET Knowledgebase for more info:

What method should | choose in ERA for my
clients to download virus signature updates?

http://kb.eset.com/esetkb]
ndex?page:content&id:SOLNZBi
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Figure 1-1: the Server Options window
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Figure 2-1: Windows Explorer page displaying text froma
successful Mirror server connection
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Section 4: Configuring a default policy

ESET Remote Administrator allows you to customize the way ESET NOD32 Antivirus
protects your client computers. To do this, you'll need to create a default policy that
is pushed out to your clients along with the install of your ESET security software.

‘stimated time: 15 minutes
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From ESET Remote Administrator, click Tools - Policy Manager.

You'll see a server icon labeled Server Policy (your server's name). Click it and then
click Edit... on the far right of the Policy Manager window (Figure 3-1, at right). In the
example, the server is named Testserver.

This will launch the ESET Configuration Editor — the tool you will use to customize e
your clients' ESET NOD32 Antivirus settings. SR

. . ) ) BeiehPoioyTie | Tt
For the purposes of this Quickstart Guide, we're going to set up a Default )

Workstation policy — a set of simple configurations that will work on most basic
networks — with no hassle for you. If you have highly specific network settings or
proprietary software that may need special permissions, check the ERA Manual for

Figure 3-1: Remote Administrator Console > Tools > Policy Manager

detailed information on building your own custom policy.

4.1 Protect setup parameters

First, we want to make sure your clients’ ESET software is not
changeable by anyone but you or other qualified users. Near the top of
the Configuration Editor tree, click ESET Smart Security, ESET NOD32
Antivirus » ESET Kernel -» Setup - Protect setup parameters.

When Protect setup parameters is highlighted, click Mark on the right.
Next, double-click Password to unlock: <Password is not set>. You will
be prompted to choose a password that will be used to allow modification
of your ESET security settings on each of the workstations. We recommend
picking a password different from the one from Step 2.1 because you may
wish to share one but not the other. Once your password is set, anyone
wishing to alter ESET settings on the client(s) will be prompted for it.

NOTE: This only affects changes made from the workstations themselves.
You can still alter settings remotely from the ERA Console without
password authentication.

4.2 Disable splash-screen and nonessential notifications

Now, we want to ensure that your client computers aren't being notified
about activities ESET NOD32 Antivirus performs in the background. A little
farther down the Configuration Editor tree, click ESET Smart Security,
ESET NOD32 Antivirus -» ESET Kernel »Setup - Default user interface
values. Highlight Suppress user settings and then select the Value: Yes
/ No check box. This will ensure that your settings override any custom
settings a user might choose. Next, highlight Show splash-screen at
startup and on theright, deselect the Value: Yes / No checkbox. Then,
highlight Display only notifications requiring user intervention and on
theright, select the Value: Yes / No checkbox. Your users’ computers will
not be disrupted by unnecessary messages from their antivirus software.

4.3 Configure clients to update from the Mirror

Next, scroll down the Configuration Editor tree and click Update module -»
Profile (My profile) » Setup » Update server: <Choose automatically>.
Here, we want to configure your clients to update from the Mirror we set
up in step 3.1. With Update server: highlighted, click Mark and then on the
right, select <Custom update server> from the Value: drop-down menu.
In the Value: field, now enter the http address of your Mirror. This will look
something like

http://Testserver: 2221
(Where “Testserver” is your server computer and port 2221 is the default port. Be sure

"

there are no spaces between the server name, the colon [*:"] and the port number.)

ERA manual

Check the ESET Remote Administrator manual
for more info:

5.3 Policies
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Click the Save diskette icon to the save the configuration and then click Console to
exit the configuration editor.

Figure 4-1: Remote Administrator Console > Tools > Policy
Manager > Configuration Editor
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Section 5: Pushing out ESET NOD32
Antivirus to your network

Well, you've installed the Console and the Server components of ERA and you've
set up the Mirror. You've even built a default policy into your Remote Administrator
settings, so no further customization is necessary.

The last big step is getting your ESET security software out to your clients. To do this,
ESET Remote Administrator creates a Package (an installer that can be run remotely)
and sends one out to each computer on your network so you don't have to walk
around from terminal to terminal installing ESET NOD32 Antivirus on each one.

Before you create and “push out” (send) your package to clients, let's briefly confirm
that your network is ready for package installation.

5.1 Push installation checklist

This manual assumes that your client machines all have basically the same
configurations across your network. Therefore, the configuration checklist below
only needs to be fulfilled on a single client machine because all other clients should
look the same.

¢ First—and perhaps most important — you need to ensure that any prior antivirus
software is uninstalled across your entire network. Running two antivirus
products can cause your system to be unstable and can interfere with crucial
operations your ESET product needs to perform to protect your network. Follow
the KB connection link at right for more information and a list of common
uninstaller utilities.

Next, confirm that Use simple file sharing (Recommended) is deselected on
all workstations in your network. From Windows Explorer, navigate to Tools =
Folder Options - View and deselect the option if it is selected by default.

+ Next, make sure the client workstation(s) on which you are installing ESET
NOD32 Antivirus have the shared resource ADMINS activated. Confirm this by
clicking Start » Control Panel » Admin Tools » Computer Mgmnt - Shared
Folders - Shares.

= Now, on the client workstation(s), open a command prompt to verify that the
workstation can access IPC. Type :

net use \\servername\IPCS
(where servername is the name of the server running ERA).

If this command returns anything other than ‘The command completed
successfully, contact your network administrator before proceeding with push
install.

» Your network's hardware or software firewall must not block communications
or file sharing between the servers and the workstation. Contact your vendor for
support. This also applies to the Windows Firewall.

°  Ports 2221-2224 must allow ESET Remote Administrator to communicate. If the
server has any of these ports blocked, communication with the workstations is
not possible.

»  ForWindows Vista machines, User Account Control (UAC) should be disabled.
¢ Theclients and the server must be visible on each other’s Network browsers.

»  Confirm that"File & Print Sharing for Microsoft Networks" is enabled by checking
Control Panel » Network Connections -» Network - Properties.

¢ Click Start » Run on the workstation and type services.msc. You will need to
confirm that the Remote Procedure Call (RPC) service is started and that
the Remote Registry service is also started. Then, confirm that the Remote
Procedure Call (RPC) Locator service is set to'manual’.

Estimated time: Varies based on
installation checklist, number of seats,
prior AV uninstall. Up to one hour.

KB connection
Check the ESET Knowledgebase for more info:

Push installation requirements and checklist

http://kb.eset.com/esetkb]
ndex?page=content&id=SOLN81

KB connection

Check the ESET Knowledgebase for more
info:

Uninstallers (removal tools) for common
antivirus software

bttp://kb.eset.com/esetkb]
ndex?page=content&id=SOLN14
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5.2 Creating a package

Once you've verified that your client network is ready to install ESET NOD32
Antivirus, you will need to create a package installation from the ESET Remote
Administrator Console. Open it by clicking Start » All Programs - ESET - ESET
Remote Administrator Console. At the bottom of the ERAC windowy, click the
Remote Install tab. After changing tabs, click the Tools menu and click Manage
Packages.

To add an installation package, click Add... in the Installation Packages Editor
window.

Click"..." and browse for the .msi installation file (eavbe_nt32_enu.msi) you
saved to your Desktop in step 1.3. Make sure the version number is current and
that you have the correct package selected. This information is displayed in the
Product Info field. Click Create.

Click Save As and give your installation package a descriptive name, such as“"ESET
NOD32 Install”. Then, click Save and click Close to return to the ERAC window.

5.3 Pushing out the package

Now that the installation package is ready, just choose the client computers
from the ERAC and send it out. To do so, click the ERAC Remote Install tab and
select the clients to which you would like to push out the installation package.
Right-click the selected clients and click Push Installation from the context
menu. This may also be accomplished by clicking Actions and then clicking
Push Installation.

In the Computers Logon Settings window that pops up, you can set the domain
logon information for each computer. Select the computer(s) from the list and click
Set or Set All, based on whether you need to specify logon information for each
computer or all at once. Enter the logon information in the pop-up window and click
OK. Click Next.

In the Package Settings window, select ESET Security Products package from the
Type drop-down menu. Select your saved installation package ("ESET NOD32 Install”
from step 5.2) from the Name drop-down list.

Name your Remote Install task and set the time you'd like it performed (immediately
or on a specific date and time) in the Task Settings window. Click Finish to apply
your Remote Install task.

After you have completed the installation process, click the Clients tab at the the
bottom of the ERAC window and wait for your client computers to check in. When
all of the computers to which you pushed ESET NOD32 Antivirus appear in the
righthand area, your push installation is complete.

NOTE: Some clients may report an update failure immediately after installation. This is
because they have not yet recieved the policy created in Section 4. This will automatically
resolve within an hour.

For tips on installing ESET NOD32 Antivirus on your server itself, see the KB
connection link at right.

You are done with the basicinstallation and configuration of your ESET security
product. Your network is now protected.
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Figure 5-1: the Package Creation window
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Figure 6-1: Select your client computers from the Computers tab

on theright. Right click them and click Push Installation.

KB connection

Check the ESET Knowledgebase for more info:

How do | push install or uninstall to client(s)
using ESET Remote Administrator (ERA)?

http://kb.eset.com/esetkb]
ndex?page=content&id=SOLN224

KB connection

Check the ESET Knowledgebase for more info:

What are the recommended settings for ESET
NOD32 Antivirus installed on a server? (4.0)

http://kb.eset.com/esetkb]
ndex?page=content&id=SOLN2144
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